weird forum issues?

A place for general discussions about anything and everything.

weird forum issues?

Postby Kuragari » Thu Dec 19, 2019 1:53 pm

Anyone else getting messages like these when posting or accessing certain pages?

g] PHP Warning: in file [ROOT]/includes/message_parser.php on line 69: preg_match(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 69: preg_match(): The /e modifier is no longer supported, use preg_replace_callback instead

[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 512: Trying to access array offset on value of type bool
[phpBB Debug] PHP Notice: in file [ROOT]/memberlist.php on line 513: Trying to access array offset on value of type bool
User avatar
Kuragari
 
Joined: Mon Jul 25, 2011 9:27 pm
Location: Indiana, USA

Re: weird forum issues?

Postby Kuragari » Thu Dec 19, 2019 2:09 pm

spoiler codes and other things also seem to not be working anymore.
User avatar
Kuragari
 
Joined: Mon Jul 25, 2011 9:27 pm
Location: Indiana, USA

Re: weird forum issues?

Postby musical74 » Thu Dec 19, 2019 9:14 pm

Happened too quick for me to see what it was, but there was "something" right before the "post was successful" thing. Maybe tied to a webpage glitching?
User avatar
musical74
 
Joined: Wed Dec 01, 2010 5:58 am
Location: Somewhere in the Neko clan

Re: weird forum issues?

Postby MiscChaos » Fri Dec 20, 2019 3:45 am

Issue has been reproduced and reported. Will let you know when it is resolved
There's organized chaos, then there's normal chaos. And then there's miscellaneous chaos...
Moderator primarily hanging out in the RP section
Also, ran the Pokemon RP!
User avatar
MiscChaos
Moderator
 
Joined: Wed Aug 03, 2011 6:03 am
Location: In the smell of brewing coffee

Re: weird forum issues?

Postby Renara » Sat Dec 21, 2019 2:43 pm

Sorry, recently installed some updates to the server, including an update to a newer PHP version; I thought I'd tested enough but it seems specific BBCode tags were affected, not all of them for some reason, so the ones I tried didn't cause the problem, bah!


For those interested, older versions of phpBB use a horrible old pattern matching option /e (eval) which PHP stopped supporting a while ago, which caused all pattern based replacement functions to break where that option is used, and sadly its used heavily for BBCode; I replaced all of these, but it seems the newer version of PHP has also broken pattern matching if the option is found there too, even though it's harmless when matching (as no replacement takes place).

Anyway, I've fixed it again where this occurs for the time being; really, really need to find the time to properly upgrade to either a newer version of phpBB or another forum software that has the features we need.


If you still encounter this warning anywhere, please post here or PM me directly (if you can)
Renara (team twitter | newgrounds)
Team Lead Programmer
Lok Team Member
Site Administrator
User avatar
Renara
Foxy Admin
 
Joined: Fri Jan 08, 2010 4:16 pm

Re: weird forum issues?

Postby Kuragari » Sun Dec 22, 2019 3:17 pm

Roger roger, will keep an eye out, and glad to hear that it should be fixed~

EDIT: Well okay, had a sudden issue trying to reply here.

[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_messenger.php on line 451: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_messenger.php on line 212: Illegal string offset 'entopic_notify'
User avatar
Kuragari
 
Joined: Mon Jul 25, 2011 9:27 pm
Location: Indiana, USA

Re: weird forum issues?

Postby Renara » Sat Dec 28, 2019 2:27 pm

Kuragari Wrote:Roger roger, will keep an eye out, and glad to hear that it should be fixed~

EDIT: Well okay, had a sudden issue trying to reply here.

[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_messenger.php on line 451: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_messenger.php on line 212: Illegal string offset 'entopic_notify'

Thanks, this should be fixed too!

This one's weird, as it's just a flat out bug with phpBB not resetting some values properly; the odd part is that it was a bug before the upgrade, so I'm not sure why it's only surfaced now, maybe earlier PHP versions just ignored them?
Renara (team twitter | newgrounds)
Team Lead Programmer
Lok Team Member
Site Administrator
User avatar
Renara
Foxy Admin
 
Joined: Fri Jan 08, 2010 4:16 pm

Re: weird forum issues?

Postby Hugh mann » Wed Jan 01, 2020 3:51 am

A screen displaying this message appears briefly before the profile page loads, afterwards it is displayed at the top of the page.
Spoiler (click to show/hide):

Screenshot-2019-12-31 Legend of Krystal Forums • Viewing profile - Renara.png
User avatar
Hugh mann
 
Joined: Fri Sep 23, 2016 3:03 am

Re: weird forum issues?

Postby Renara » Sun Jan 26, 2020 1:40 pm

Hugh mann Wrote:A screen displaying this message appears briefly before the profile page loads, afterwards it is displayed at the top of the page.
Spoiler (click to show/hide):

Screenshot-2019-12-31 Legend of Krystal Forums • Viewing profile - Renara.png

Whoops, I saw your post not long after you submitted it, but forgot to say I'd fixed it. (Late) thanks for letting me know about it!
Renara (team twitter | newgrounds)
Team Lead Programmer
Lok Team Member
Site Administrator
User avatar
Renara
Foxy Admin
 
Joined: Fri Jan 08, 2010 4:16 pm


Return to General



Who is online

Users browsing this forum: No registered users